Recently, we needed to create a visually strong, photo-realistic short interstitial for the Basketball Championship League series in Germany— and had roughly half an hour to do it!

Armed with a medium-resolution image of a patterned wooden floor, a beautiful HD rendering of a spinning basketball from Artbeats, and a handful of interesting 3D tricks in After Effects, the goal wasn’t quite so unrealistic. Here’s how we did it...

Tutorial Project Specs:
Adobe After Effects CS5
HDTV 1280x720 px
6 seconds @ 25 fps

This PDF is interactive!
We highly recommend viewing with Adobe Reader

www.artbeats.com
Start out in Adobe After Effects CS5, and go to Composition > New Composition. In the dialog box, choose the HDV/HDTV 720 29.97 preset, a duration of 6 seconds, and the background colour to black. Name it “Game On Comp” and click OK.

We needed a wooden texture to establish a floor for the basketball court, so we searched online and located just the right image, then downloaded it in medium resolution.

In the Project Panel, double-click in an empty area to bring up the Import dialog box, locate the wooden texture file you have downloaded or wish to use, and click Open to bring it in. Then drag it down into the Timeline at 0 seconds.
Now we need to make this a 3D scene, which mainly involves two things—at least one 3D layer, and a 3D Camera. In the Timeline, select the wooden floor layer, then hit Return on the keypad so you can rename it “Wooden Floor.” It just makes things easier to deal with than long internet-based names.

Now, under the Switches column, click the 3D Layer switch for the wooden floor layer. You'll likely see a warning telling you that you need a 3D Camera, but you can dismiss it as we'll be taking care of that. Then, hit R on the keyboard to reveal the Rotation property of the layer, and set the X Rotation to –90°, putting the floor on its back, perfectly perpendicular to us.
Now we need to add and position the main 3D Camera which enables the scene to come together. Go to Layer > New > 3D Camera, and choose 28mm from the Preset drop-down menu.

This will add the camera in the center of the scene also at 360px on the Y axis (half of the 720 comp height), so we need to move it up above the floor.

First, with the Camera selected, go to Layer > Transform > Auto-Orient, and make sure that it is turned Off. After Effects CS5 has this feature already set (thankfully!), but older versions of After Effects have the camera set to focus on its Point of Interest. This can be handy in some situations, but in my overall experience of working in 3D in After Effects, I personally much prefer orienting the camera manually, or with nulls and expressions for more natural movement.
Hit the P key to reveal the Position properties for the Camera layer, and for now set the Y axis to around 0px, which puts it up above the floor. Now, hit Shift-R to also show the Camera’s Rotation properties, and set the X Rotation to -25° to tilt the camera down a little to where we can see the floor.

Now, depending on the image you have selected for the floor, the chances are you can see the edges—not what we want. We need the layer to be big enough to extend all around the field of view, but not be so large as to destroy the image pixels, nor the overall scale of the scene.

First, set the floor layer’s Z Rotation to 50° which nicely angles it across the field of view.
Now, go to Effect > Stylize > Motion Tile, and in the Effect Controls Panel (ECP), adjust the Output Width and Output Height sliders (not Tile Width or Tile Height) until the floor extends beyond the comp's edges on both sides. Pretty nice, eh?

Now, also click the Mirror Edges switch, and this should create a much smoother and realistic tile of your floor.
Now we want to "light" the court floor, as if there is only one spotlight in the entire room, in the center of this section where the ball will be. Trouble is, 3D lighting will take longer to set up and render, so we can cheat this effect using a soft-edged mask layer.

Go to Layer > New > Solid, and in the Solid dialog box make sure the size is square (in this case I am using 1200x1200), set the colour to Black, and name it "Shadow Solid." Click OK and it is added to the Timeline at 0 seconds. Be sure to click the 3D Layer switch for it.
Press P, then Shift-R and Shift-S to reveal the Position, Rotation and Scale properties for the layer. First, set the X Rotation to -90° so it flips over to match the wooden floor, then go to the Y Position and change it to 269px to nudge it just one pixel above the floor. This can avoid any potential layer intersection errors during rendering if the layers occupy the exact same pixel location.

Now, go to the Tools panel, click and hold on the Rectangle Tool until you see the Oval Tool, then select it. Then, simply double-click that very same tool to add a perfectly circular mask to the black solid layer, then press V to go back to the main Selection Tool.
With Mask 1 still highlighted in the Timeline, press Cmd/Ctrl-T to Free Transform the mask. In the Composition panel, grab one of the corner points and, holding down Shift and Cmd/Ctrl, drag inwards to scale the mask down to about 20% its original size. Bear with me on this one :) Now, in the Timeline, click the Inverted switch to reveal the rest of the black layer and our mask becomes the hole—or the spotlight—in the shadow! Now, adjust the Scale value for the layer until the outer black edges go out of the field of view covering the rest of the wood, and then if necessary fine-tune the scale of the circular mask using the same techniques as the beginning of this step. Finally, hit F to reveal the Mask’s Feather value, and adjust the soft edge until your spotlight is perfect!
Now to add the basketball, and naturally this comes as a stunning HD looping clip from Artbeats! We did a search for Sports Balls on their Artbeats.com site, and came up with SBE122H from the Sports Ball Elements HD collection. After downloading and importing the clip, drag it into the Timeline at 0 seconds above all the other layers. You’ll see it comes in with a black background, which needs to be removed—but now you can use the Oval Tool to create a circular mask, shape it and position it, you now know how to do this! As this clip is such high HD quality, double-click the layer in the Timeline to bring it up in a Layer Window, then you can zoom in or out and create your mask around the ball easily.
Now close the Layer window, and back in the Timeline, be sure to click the 3D Layer switch, then show the Position and Scale Properties. Scale and drag the ball into the right position for your composition—in this case, I scaled it down to 22%, and moved it to 750, 185 and -450 on the XYZ axes respectively.

Doing this highlights one thing about 3D in After Effects. It’s not 3D... The ball is a 2D layer, which is now off to the side of a camera view, and is looking distorted. Thankfully, there’s a cool and easy fix for that, one which we briefly saw earlier on the camera...
With the baller layer still selected, go to Layer > Transform > Auto-Orient, and choose Orient Towards Camera. Perfect! Now, wherever your camera moves or tilts, the ball will always look perfectly spherical!

The ball clip is 30 seconds long, and the “spin” is quite slow, so let’s speed it up. In the Timeline, click the small {} switch in the lower left to show the Time Stretch column, and adjust the Stretch value to 21% for the ball, which will happily fit the 6 seconds of the comp. You can preview the speed of the ball by clicking the Solo switch for the layer in the Timeline, and press 0 on the keypad to perform a RAM Preview. Much better!
With the wooden court floor likely being shiny, adding a reflection of the ball would be really cool—and very easy! First, hit Return on the ball layer and rename it “Main Ball.” Then press Cmd/Ctrl-D to duplicate it, and name that one Reflection Ball, then drag it down to below the other layers in the Composition.

Reveal the Position and Scale properties for the Reflection Ball layer, and adjust the Y position so it sits below the floor (which is at 360px remember), so in the region of 480px should be fine. Now with the main ball, you can see a nice blue-ish highlight on the lower right, almost like bounced light coming up from the floor. But the reflection doesn’t show the same thing...

So click the Unlink Scale icon next to the Reflection Ball’s Scale values, and set the Y Scale to -22%. Now, it’s upside down and perfectly matches the Main Ball above, and still rotates in the same direction!
Now, un-solo those layers so you can see the entire design again, and you'll see the reflection now disappear as it's below a solid floor. But more After Effects trickery will fix that... Simply click the Toggle Switches/Modes button in the Timeline, and choose Overlay. Nice! Now, select the Reflection Ball layer and hit T to reveal its Opacity property, and drop it to around 40%.

Finally, go to Effect > Blur & Sharpen > Fast Blur, and in the ECP set a Blurriness value of around 6px just to soften the edges and blend it in a little more realistically with the softer wood effect. Looking really nice... One more thing missing, is a shadow. Remember, there's a virtual spotlight in this scene...
The cool thing is, you already know how to do this, as it’s the same process we used to create the outer black feathered spotlight edge, only smaller and not inverted!

In the Project Panel, drag the Shadow Solid item from the Solids folder once more into the Timeline at 0 seconds, below the Main Ball layer, and click its 3D Layer switch. Just as you did with the other shadow layer, change the X Rotation to -90°, and its Y Position value to 359px.

Most importantly, it needs to sit directly beneath where the Main Ball is, so change the X and Z Position values to be the same—in this case 750 and -450px respectively. And if it makes you feel more comfortable, you can change its Z Rotation value to 50° to line up with the floor pattern.
Now, using the same technique as before, double-click the Oval Tool to create a circular mask on this square layer. Press V for the Selection tool, then use Cmd/Ctrl-T to access Free Transform for the mask, and then Cmd/Ctrl-Shift-drag a corner point down until the mask is the rough size you wish the shadow to be.

Then hit F for the Feather value, and adjust to whichever softness you desire. Finally, adjust the Opacity of the Shadow layer by perhaps 10-15% so the wood and reflection beneath just show through. With the right combination of mask size, mask feather and layer opacity, you can achieve utterly astoundingly realistic shadows this way... and we've not used a single light!
The project at this stage is essentially finished—but with the embellishment of camera moves, additional graphics and/or shadows, and of course the show titles, this shot becomes so realistic it looks like film with extensive motion tracking and rotoscoping. None of those things were required; just half an hour of After Effects time and a little imagination. Enjoy!

www.artbeats.com
A few words about
Steve Holmes // Energi Design

Award-winning British designer Steve Holmes is the Founder and Creative Director of Energi Design in Sausalito, California.

After studying design and typography for print, and being studio manager at two design and print production companies, he established Energi Design in London in 1994, creating layout, web design, and video motion graphics for clients such as Nike, Warner Bros, Disney, Coca-Cola, Virgin Atlantic, Sainsbury’s, Toyota and Cadbury’s Chocolate, to name but a few.

For the last decade, he has spoken on Adobe’s behalf at design seminars and conferences all over Europe and America (NAB, Siggraph, HOW Design Conference) on the subjects of design, typography, web design and motion graphics between After Effects, Illustrator and Flash.

Moving to California in 2002, he worked alongside Total Training for 3 years as their Director of Design & Animation Training, hosting multiple award-winning video training series, and is widely recognized in the motion graphics industry as one of the After Effects “heads of state”.

With Energi Design now settled in San Francisco, California, Steve runs the studio as Creative Director, and their design work has garnered no less than three Webby Awards, one W3 Award and one Davey Award in the last three years for their Flash design, motion graphics and commercials for clients such as Adobe, Hiball Energy Drink, Artbeats, Virgin America, Sotheby’s International Realty and Le Tournant Vert Absinthe.

Visit Energi Design on Facebook