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How to color manage Artbeats clips 
in After Effects CS3.

Tips & Tricks
More available at artbeats.com

page 1

Figure 1:The Project Working Space in After Effects is set in the File > Proj-
ect Settings dialog. A common choice is to set it the same as the format you 
will be rendering to, such as SDTV for standard definition video or HDTV 
for high definition video.

After Effects CS3 has introduced the concept of “color management” 
to the motion graphics world. Color management is based on the 
admission that in the real world, nothing’s perfect: Different formats 
(such as video cameras, still image cameras, computer-generated 
imagery, etc.) have different biases when it comes time to capture 
or create an image. Likewise, different output formats and devices 
- such as television sets or web browsers - have different biases as 
well. Additionally, computer monitors also have their own biases. 
When all these devices have potentially different ideas of how “red” 
a rose is, how do you know when you’re seeing the truth? The an-
swer is to identify each of these biases (also known as “profiles”) and 
to compensate for them as you travel through the processing chain.

In this article, we’ll give you an overview of how to set up a color 
managed workflow in After Effects CS3, with specific advice on how 
to best handle stock footage shots from Artbeats. There are essen-
tially four pieces to the puzzle: The Project Working Space, the Input 
Profile, the Output Profile, and the Display Profile.

Project Working Space
The Project Working Space (PWS for short) is the central reference 
color space you will be using in your project. It is set in File > Proj-
ect Settings. Every source will be translated into that space, compos-
iting will take place in that space, and the result will be translated 
from there into the output space. So obviously, it’s choice is very 
important.

The most common choice for the PWS is to make it the same as the 
format you expect to be rendering to. For example, if you are going 
to be rendering to a high definition video format such as HDV, set 
this to HDTV (Rec. 709); if you are rendering to a standard defini-
tion format such as D1 or DV using the NTSC standard, choose 
SDTV NTSC. By doing this, since the result of a composite in After 
Effects will already be in the same color space as your output, you’ll 
be cutting out at least one translation (and therefore, one less chance 
for math errors) in your workflow. This approach has another advan-
tage if you are using the Video Preview feature inside After Effects, 
or are otherwise checking your work on an actual video monitor: Set 
the PWS to be the same as your external video monitor, and com-
positing will take place in the same color space as is being used by 
that monitor. (We’ll discuss monitoring in more detail later in this 
article.)

If you don’t know what your output format will be, the next best 
choice is to set it to match a format that matches the majority of your 
sources (which we’ll also discuss in a moment). This way, you will 
be cutting out a translation on input.
Another approach is to choose a “large” color profile for the PWS 
that encompasses the widest possible range of colors during the 
compositing stage, and then translate from this to your required 
destination on output. This is a good choice for the most critical 
applications, such as going to film. In this case, Adobe suggests you 
use their ProPhoto RGB profile.
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Figure 2: Verify that the correct color profile is being used for each clip. 
Open its Interpret Footage dialog and look under the Color Management 
tab. After Effects CS3 usually defaults to sRGB for Artbeats clips, which is 
wrong; change it to SDTV or HDTV depending on the video format of the 
clip.
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Input Profile
After you have set the Project Working Space, you will now be 
allowed to set the Input Profile for each of your footage sources. 
To access this, select a source in the Project panel, and go to File 
> Interpret Footage > Main. In the dialog that appears, click on the 
Color Management tab, and set the Assign Profile popup to match 
your footage.

figure 4

movies - the format used by Artbeats for most of their clips), then 
After Effects may pick the wrong format. For example, After Effects 
CS3 likes to default to sRGB, which is correct for most web and 
computer graphics, but wrong for video.

In this case, you will need to manually set the Assign Profile popup. 
But what’s the correct choice? It depends on where the clip came 
from. Artbeats clips have been optimized for use in video projects, so 
if you have a standard-def clip, pick SDTV (NTSC or PAL, depend-
ing on your format); if you have a high-def clip, pick HDTV (Rec. 
709, which is the official number of the HD spec).

This is where things get a little tricky. On the one hand, if you are 
running After Effects on a computer with an Intel processor, some 
formats - such as DV - will have the correct profile chosen for you 
automatically by a new technology in After Effects known as Media 
Core. On the other hand, if you are using an older (pre-Intel) Macin-
tosh computer, or if your footage is in a format that Media Core does 
not automatically handle (such as Photo-JPEG encoded QuickTime 
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Figure 3: What is the correct profile for a clip? For a V-Line clip such as 
VWD109 from the Washington DC collection (a), the correct choice is SDTV 
NTSC; for a synthetic render such as LAL113 from the Light Alchemy col-
lection (b), it may be sRGB to better match the computer monitor the clip’s 
creator may have been working on.
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Of course, there can be exceptions to every rule: If you choose what 
you think the right profile should be, but the result doesn’t look quite 
right, there are a few other options you can try. For example, if the 
clip is a purely synthetic 2D or 3D render, chances are the creator 
was looking at a computer monitor rather than a video monitor 
while creating it. If they were using a Mac, then Apple RGB may 
be a more accurate choice; if they were using Windows, then sRGB 
may be more accurate (as most Windows PC monitors default to the 
sRGB color space). Try both and see if one looks “better” (yes, we 
are talking a subjective judgment at this point - but it’s a synthetic 
image to begin with, so there’s no “reality” to worry about being 
faithful to).

If a clip looks washed out, then there is a chance it was encoded 
using a 16-235 video luminance range rather than the full computer 
0-255 range. A good way to check your hunch is to add the clip to a 
composition, apply Effect > Color Correction > Levels, and look at 

the Histogram in Levels: If you see gaps at the left and right ends 
of the Histogram, it’s probably a 16-235 clip. Remove or disable 
Levels, then go back to the Interpret Footage dialog for this clip 
and set its color profile to SDTV or HDTV 16-235: The result 
should look better.

Output Profile
Unlike Input Profile, where you need to manage the color profile 
for each source, Output Profile is easy: You only need to set it 
once when you render. In the Render Queue, open the Output 
Module’s options and click on the Color Management tab. Set 
the Output Profile popup to match the format you are rendering 
to, such as SDTV or HDTV. This defaults to matching the Project 
Working Space - so if you followed our earlier advice for setting 
the PWS to match your desired output format, you’re already 
done.

Figure 4: If footage seems to be lacking in contrast (a), apply a Levels effect 
and look at its Histogram (b). The gaps on the left and right ends of the 
Histogram are a clue that the luminance range of this clip might actually be 
16-235. Remove the Levels effect, go back and change its Input Profile in the 
Interpret Footage dialog (c), and now the clip will have more contrast (d). 
(Clip TR1117 from the Artbeats collection Retro Transportation.)

figure 4a

fig
ur

e 
4b

fig
ur

e 
4c

figure 4d



page 4

Tips & Tricks
More available at artbeats.com

Figure 5: Set the Output Profile in the Output Module to translate colors 
from the Project Working Space to the file format you are rendering to. If 
they are the same, no translation is necessary.

The nice thing about this option is that if you are rendering to more 
than one format - such as video, but also a web version or a Quick-
Time client proof - you can add extra Output Modules to the same 
render, and give each one its own profile (for example, sRGB for the 
web, or Apple RGB if the client will be viewing a QuickTime proof 
on a Mac). After Effects can then translate the colors from its PWS 
to match the environment the clip will ultimately be viewed in.

Monitor Profile
Now that we have color management working throughout the After 
Effects image processing pipeline, that last step is making sure 
you’re viewing the colors accurately while you’re working.
If you are viewing your work on your computer monitor, you will 
want to make sure your operating system is using the correct profile 
for your monitor so that it can properly translate the colors being 
displayed inside After Effects. Under Windows, the place you will 
find this can vary depending on specific operating system; Control 
Panel > Display > Settings > Advanced > Color Management is a 
typical path. Most PC monitors either default to sRGB or have an 
sRGB option, so this is a good choice most of the time. On the Mac, 
look under System Preferences > Display > Color. In our experience, 
the Mac chooses a good profile if you are using a built-in screen or 
Apple Cinema Display, but its color profiles for other monitors don’t 
look right. As most non-Apple monitors are made with the assump-
tion they will be used under Windows, sRGB is a good alternative 
choice.

The absolute best approach is to create a custom profile for your 
monitor. Get a monitor profiler (Pantone, ColorVision, and Gretag 
Macbeth are popular manufacturers) and have it create a translation 
that matches your specific monitor and video card.

As hinted earlier, if you are using the After Effects Video Preview 
feature, your windows are being blasted out to your external video 
monitor without any additional color correction. In most cases, your 
external monitor will be of the same video format as your intended 
output. If not, then for critical color correcting, you will want to 
temporarily change the Project Working Space to be the same as 
your external monitor, so that After Effects will translate all of your 
sources into a matching color space before it creates the image you 
will be previewing.

Zooming Out
There is one huge fly in the ointment as of the time this was writ-
ten (early 2008), and it has to do with differences in the way Adobe 
and Apple handle “gamma” tags inside QuickTime movies. Without 
dragging you through the gory details, in short: If your intention is 
to render a QuickTime movie that will look the same inside Adobe 
applications on Windows as it does inside Adobe applications on 
the Mac, go into Edit > Project Settings and make sure the “Match 
Legacy After Effects QuickTime Gamma Adjustments” option is 
off. On the other hand, if your workflow is from After Effects to an 
Apple application such as QuickTime Player or Final Cut Pro, then 
turn this option on. It defaults to off, but will be turned on automati-
cally if you open a pre-CS3 project in After Effects CS3.

Figure 6: We sometimes have trouble with Apple’s color profiles for non-
Apple monitors. For example, even though this computer has an NEC 
LCD1830 display, and Apple has a profile for it, we get better results select-
ing the sRGB profile in the Mac’s System Preferences.



For even more tips and tricks, Chris and 
Trish Meyer have just released the fourth 
edition of their book Creating Motion 
Graphics with After Effects. Most of the 
examples use Artbeats footage at full D1 
size. To learn more, visit: 
http://www.books.cybmotion.com.
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Adobe has done a nice job in making available additional informa-
tion on Color Management in After Effects CS3. For a general back-
ground plus several example workflows, download and read their 
technical paper on the subject: http://www.adobe.com/go/learn_ae_
colormanagementpaper. For more on the gamma issues mentioned 
above, visit http://www.adobe.com/go/learn_ae_quicktimegamma.

Color management may seem like a new, scary, complex thing to 
learn, but in reality, it’s the best way to go. After all, what’s the point 
in shooting, editing, and compositing the very best image you can, 
only to have your colors translated into the wrong space? Learn color 
management, and you can deliver the image you really intended to.

###
Chris and Trish Meyer are the founders and owners of CyberMotion 
(www.cybmotion.com), an award-winning motion graphics studio 
in Los Angeles that has created a wide variety of work for film, 
broadcast, corporate events, and special venues. They were one of 
the original development sites for After Effects, wrote the highly-ac-
claimed books Creating Motion Graphics and After Effects Appren-
tice (2007), and are long-time Artbeats users.

Figure 7: If your workflow takes you between Adobe applications on the 
Mac and Windows, disable the “Match Legacy Gamma” option. If your 
workflow takes you from After Effects to Apple applications such as Quick-
Time Player, enable this option (as we have here).


