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handle video content.
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Figure 1: With interlacing, two fields captured at slightly different points in 
time (a,b) are woven together to create an interlaced frame (c). Televisions 
and video software know how to unweave these to get back to the source 
frames, but web software and developers often skip this step. This is clip 
VRS120 from the Artbeats Recreational Sports (V-Line) collection.

We live in a world where content often appears in more than one 
media format. For example, web cartoons created in programs such 
as Adobe Flash may be picked up for broadcast, while video content 
appears regularly on the web (YouTube, anyone?). Despite this, 
many web developers have not yet mastered digital video’s numer-
ous idiosyncrasies. And unfortunately, there is a lot of bad advice out 
there about how to deal with them. Therefore, we’d like to give the 
web developers out there (as well as video newbies) a list of issues to 
be aware of while repurposing video for the web – namely, interlac-
ing, pixel aspect ratio, frame rate, and color space.

Playing the Field
The biggest single technical difference between video and the 
computer has to do with interlacing or fields. Some – but by no 
means all – video is captured or created using a process known as 
interlacing or field rendering. We discussed this subject in detail in 
the Tips N Tricks article Managing Interlaced Footage; let’s review 
it here. 

When interlacing is employed, two images are captured or created 
for every single frame of video. These two images are known as 
fields. The two fields are offset slightly in time – namely, by half 
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the duration of a single frame. Alternating horizontal lines are taken 
from these two fields and woven (interlaced) together to create a 
frame. Televisions and related video equipment expect this, and 
un-weave (deinterlace) the fields before they are displayed, playing 
them back in the proper order to create smooth motion.
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Figure 2: In After Effects (a), open the Interpret Footage dialog and set the 
Separate Fields popup, enabling Preserve Edges for additional quality. In 
Motion (b), use the Field Order popup under the Inspector > Media tab. In 
Final Cut Pro (c), scroll over to the Field Dominance column and right-click 
on the current value to change it.
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Computers generally don’t expect image frames to be interlaced. 
Therefore, they display both fields at the same time, creating dis-
play artifacts where alternating lines appear to be offset wherever 
something moves around the frame. Therefore, if fields are present 
(and that’s a very important “if”), you will want to separate the fields 
in the source material, throw one away, and use only the remain-
ing field when repurposing interlaced content for the web. This is a 
crucial concept that many developers skip or miss!

All video software has a way to separate fields and to fill in the 
“missing” lines with interpolated pixels from the field it keeps. Your 
job is to tell the software which field occurs first in time – the one 
used for the very first line in the frame (the “upper” field), or the 

scroll over to the (technically misnamed) Field Dominance column, 
and right-click the current setting. There are also dedicated plug-ins 
such as the FieldsKit suite from RE:Vision Effects that perform these 
tasks in a more sophisticated manner that the default software rou-
tines. The correct setting to use depends on the format of the source 
footage; this was discussed in the Tips N Tricks article Managing 
Interlaced Footage we mentioned earlier.

Just as important as separating fields on input is making sure you 
don’t reintroduce fields on output. Remember, video for the web 
is never interlaced. In After Effects, you make this decision after 
you’ve added a composition to the Render Queue: Open up the Ren-
der Settings for your queued comp, and make sure the Field Render 
popup is set to Off. In Apple products, you make this setting for the 
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one used for the last line in the frame (“lower”). In Adobe After 
Effects, import the footage, select it in the Project panel, open File 
> Interpret Footage > Main and then set the Separate Fields popup; 
enable Preserve Edges to improve the interpolation quality. In Apple 
Motion, add the footage to your project, open the Project panel and 
select the footage under the Media tab, then in the Inspector panel 
select the Media tab and look for the Field Order popup. In Apple 
Final Cut Pro, import the footage, select it in the Browser window, 

project or sequence before you render: In Motion, open Edit > Proj-
ect Properties and set Field Order to None. In Final Cut Pro, click 
on the Final Cut Pro menu item, open Audio Video Settings, select 
the Sequence Presets tab, and create a new preset for your web work 
by duplicating then editing an existing preset. Then in the Sequence 
Preset Editor, set the Field Dominance popup to None.



Now, back to that important “if” we mentioned: Not all video is 
interlaced. And if it is not interlaced, you don’t want to separate the 
fields – you’d just be throwing away half of your resolution. You will 
find a large number of clips you receive are progressive scan (which 
means not interlaced – every line in a frame is from the same point 
in time). Film is not interlaced. A large percentage of computer-gen-
erated imagery is not field-rendered, and therefore is not interlaced. 
Many video cameras now have progressive scan options as well. Ad-
ditionally, Flash animations don’t have fields; neither do still images, 
scans, or illustration. 

Indeed, the vast majority of the Artbeats stock footage library uses 
the progressive scan format. You can tell by finding the clip you like 
on their web site, clicking on the “i” (More Information) icon under 
it, and looking at the Field Rendering specification for that clip; if 
you have one of their collections, look at the Specifications section at 
the end of the printed card of thumbnails that came with the collec-
tion. Progressive scan is nice because it plays well on both comput-
ers and televisions.

The point to remember is this: If a clip employs progressive scan, 
leave the separate fields option to Off or None. But if fields are pres-
ent, you always want to separate them before compressing the movie 
for playback on the web.
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Figure 5e
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Figure 3: After you separate the fields for any interlaced source footage, you 
need to make sure field rendering is turned off for your composition, project, 
or sequence. Here are the correct settings in the relevant dialogs for After 
Effects (a), Motion (b), and Final Cut Pro (c).
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What if your video clip seems to be progressive scan on some 
frames, and interlaced on others? Then it was created using a spe-
cial procedure known as pulldown. This is a trick used to spread 
whole frames from film (which usually has a lower frame rate) over 
multiple fields of video, which sometimes requires splitting source 
frames across video fields. You want to remove pulldown and get 
back to the source film frames before compressing the clip for the 
web. After Effects even has a “guess” button to try to help find and 
remove pulldown for you. (For more information on pulldown, see 
the Tips N Tricks article Getting Down with Pulldown.)

Now that you have the most complex item on your checklist mas-
tered, let’s move onto some other important subjects.

Pixel Aspect Ratio
Computers are logical beasts. For example, they assume every pixel 
should be displayed as tall as it is wide – makes sense, doesn’t it? 
Video is nowhere near as logical: Quite often, it expect pixels to be 

Figure 4: Study each clip before 
the fields are separated (such as in 
QuickTime Player): If you see the 
“comb teeth” pattern of interlacing 
on moving objects (a), the clip is in-
terlaced, and you should separate the 
fields. If you don’t see this pattern (b), 
the clip is progressive and you should 
not separate its fields. If you see both 
in the same clip – as is the case here 
(clip ES130 from the Artbeats Extreme 
Sports (V-Line) collection), the file 
was encoded using pulldown, which 
should be removed.

figure 4a

projected onto the screen either wider or skinnier than they appear on 
a computer. If you don’t compensate for this, circular logos will look 
like eggs, and people will magically gain or lose weight as television 
monitors stretch or squish them.

Fortunately, video software is familiar with this idiosyncrasy, and 
gives you options to correct it. Check each piece of source footage 
and make sure its Pixel Aspect Ratio setting matches the video’s 
format, such as “anamorphic” (widescreen) DV. You’ll find these 
settings in the same general area in the program that you found the 
field order settings. In most cases, it will be set automatically, but it’s 
a good idea to verify it just to be safe.

figure 4b
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Figure 5: Most digital video has non-square pixels. If you don’t compensate 
for this, supposedly perfect circles will appear as eggs when displayed on a 
computer (a). However, if you tag the aspect ratio of your footage correctly 
(b), most programs will compensate for this when you scale them down in 
a square pixel timeline or composition for eventual use on the web (c). Clip 
DG101 from Artbeats Digidelic.
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Just like interlacing, you have to set the pixel aspect ratio for every 
source, as well as the overall composition, project, or sequence 
you are working in. Time for another important (but occasionally 
overlooked) truism: When rendering content for the web, your output 
should always use square pixels. In After Effects, this is set in the 
Composition Settings dialog. In Motion and Final Cut Pro, it is set 
in the same dialogs as the output field order, which we discussed 
earlier.

Again, you will find more on this subject in the Artbeats Tips N 
Tricks archive: Look for the two-part series on Pixel Aspect Ratio, as 
well as Going Wide (an article on using the widescreen format).

Frame Rate
The idiosyncrasies keep on coming! NTSC format video (common in 
North America and Japan, among other places) tends to run at either 
29.97 for 23.976 frames per second (FPS). Resist the temptation 
to round these numbers to 30 or 24! If you do, there’s a chance the 
audio and video may fall out of sync with each other, and that you 
may notice hitches in the motion in your video content. Frame rate 
for your project is usually set in the same place as pixel aspect ratio. 
Be warned that many software programs provide “web” presets with 
non-NTSC frame rate; you will need to edit the rate used by these 
presets.

Flash Video (FLV) can support these oddball rates; the only excep-
tion is if you embed your video inside a SWF file – which you prob-
ably won’t, as this gives a severe limitation in the duration of the 
file. If you want to use a lower frame rate to save on data, divide this  
number by exactly 2 or 3 – again, don’t round the result.

Color Space
Most web browsers expect your artwork to be in sRGB color space – 
this is the standard on Windows, and the Safari browser on the Mac 
performs color space transformations of tagged files automatically. 
However, video exists in a color space other than sRGB. For the best 
results, you should translate your video to sRGB as you compress it 
for the web.

Unfortunately, as of the time this was written (late 2007), most video 
software is behind the curve when it comes to color management; 
you should consider using Adobe After Effects version 7 or later for 
this process. The simple technique is to add the clip to a composi-
tion, apply Effect > Utility > Color Profile Converter to the clip, set 
the Input Profile popup to match the video format (such as SDTV 
NTSC for DV or D1 footage shot in North America), and set the 
Output Profile to sRGB IEC61966-2.1. When you’ve set this up 
once, select the effect and use Animation > Save Animation Preset; 
you can then select subsequent clips and use Animation > Apply Ani-
mation Preset to recall these settings.

figure 5c
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For even more tips and tricks, Chris and 
Trish Meyer have just released the fourth 
edition of their book Creating Motion 
Graphics with After Effects. Most of the 
examples use Artbeats footage at full D1 
size. To learn more, visit: 
http://www.books.cybmotion.com.
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If you are using After Effects CS3 or later, an alternative workflow is 
to open File > Project Settings, and set the Color Settings > Work-
ing Space popup to sRGB IEC61966-2.1. Then for each video clip, 
select it in the Project panel, open its File > Interpret Footage > 
Main dialog, click on the Color Management tab, and set the Assign 
Profile popup to match the video’s format. If you do this, you won’t 
need the Color Profile Converter effect. As a bonus, you can op-
tionally change the color profile that the final file is saved to in the 
Output Module (it defaults to match your Working Space).

We hope these tips help you decode the mystery of repurposing 
video for the web. Master them, and you will be ahead of the vast 
majority of other developers! If you want more information, we’ve 
covered each topic in more depth in our books After Effects Appren-
tice and Creating Motion Graphics with After Effects. We’ve also 
created extensive video training modules on the subjects of fields 
and pulldown; they are available to Lynda.com subscribers as well as 
for individual purchase – check out articles.cybmotion.com for more 
information.

###
Chris and Trish Meyer are the founders and owners of CyberMotion 
(www.cybmotion.com), an award-winning motion graphics studio 
in Los Angeles that has created a wide variety of work for film, 
broadcast, corporate events, and special venues. They were one of 
the original development sites for After Effects, wrote the highly-ac-
claimed books Creating Motion Graphics and After Effects Appren-
tice (2007), and are long-time Artbeats users.

Figure 6: If you are using After Effects 7 or later, use Effect > Utility > 
Color Profile Converter (a) to change the colorspace of video clips from 
their own standard to the sRGB space most web pages expect. If you are 
using After Effects CS3, an alternative to this effect is to set the Project 
Working Space to sRGB (b), and then set the color profile of each clip in its 
Interpret Footage dialog (c).
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